Need help with your PC or Modding Projects?
User avatar
JC
16-bit
 
Posts: 77
Joined: Sat Aug 26, 2006 8:51 pm

Saturn Cartridge Slot Problem

by JC Sat Sep 16, 2006 6:27 pm

Anyone had a problem with the cartridge slot on their Saturn? Now I haven't had a Saturn for years, but I now have a chipped Japanese white model 2 Saturn. When I got the machine, it came with an official Sega memory cartridge. I plugged this in, and nothing came up. I seemed to remember before, going to the memory management section, and the cart memory would appear in blue under the pink system memory box on screen.

So anyway, a mate of mine gave me his 4MB ram cart that he used to use. We tested it in his machine aswell, and it worked fine. I downloaded SFZ3 (first 4MB game that came to mind), and I got the 4MB error message. I'm guessing that my cartridge slot is damaged. I've tried doing the old "blow" trick on cartridge and slot, but no luck. Any ideas or fixes for this type of problem?
User avatar
racketboy
Site Admin
 
Posts: 9486
Joined: Thu Dec 01, 2005 8:28 pm
Location: Michigan

by racketboy Sat Sep 16, 2006 6:50 pm

Open the case up and see if you can do further cleaning.
Might want to carefully clean the contacts of the cart as well.
User avatar
grittykitty
forever 16-bit
 
Posts: 949
Joined: Sat Dec 03, 2005 1:49 am
Location: sega nomad

by grittykitty Sat Sep 16, 2006 11:50 pm

i've had cartridge issues with my white saturn too. it's pretty clean though, so maybe it's just a bit worn out... find a good card and try to avoid taking it out
Let's TRADE! : check my BST thread
two-rok
Newbie
 
Posts: 1
Joined: Tue Oct 24, 2006 1:51 pm

by two-rok Tue Oct 24, 2006 2:04 pm

i have the same problem with 1 of my 2 PAL Saturns, i didn't remove the 4M Cart off but one day it started not to be detected.

the cart is two months old so it's not a problem in the cart but in saturn cart slot, i have tried opening the saturn and blowing in the cart slot with an air "gun" but it didn't work, it still doesn't detect

the other saturn i have detects the cart though.

can someone please help?
scott21
16-bit
 
Posts: 59
Joined: Sat Jul 22, 2006 2:16 am

by scott21 Tue Oct 24, 2006 3:26 pm

a friend of mine once told me to stick a piece of cardboard behind the memory card and it would help give it a tighter connection

worked for me, might want to give it a shot.
User avatar
Cerulean
64-bit
 
Posts: 355
Joined: Fri Sep 29, 2006 11:03 am

by Cerulean Tue Oct 24, 2006 3:34 pm

Maybe you can unscrew it from the mobo and clean it out? It definitely sounds like the contacts on the connectors are durrrrrrrrrtttttttyyy or dead.
Return to Technical Help

Who is online

Users browsing this forum: No registered users and 3 guests