Need help with your PC or Modding Projects?
User avatar
MasonB15
24-bit
 
Posts: 196
Joined: Mon May 25, 2009 3:15 am
Location: In a galaxy far, far away...

3DO RGB Mod Issues

by MasonB15 Sat Aug 03, 2019 9:57 pm

I attempted to mod my FZ-1 3DO which has the VP536 video encoder with the RGB board from Otaku's Store (https://www.otakus-store.net/en/all-our ... board_only)
(Install guide: https://www.otakus-store.net/en/content/18-3do-rgb)

It's not exactly working, as you can see here: https://www.youtube.com/watch?v=IBjXDPluAxE

Using the 240p switch and/or the switch to disable the RGB board does nothing. Neither Composite or S-Video are working as well, regardless of the switches. I've double checked each of the 8 R, G, and B connections to make sure they aren't bridged, I've double checked the schematic, I've double checked the pinout of my cable, double checked the cable itself, and I've completely come up empty.

I realize that this is an obscure issue for a relatively obscure console, but has anyone encountered this issue before? Any ideas for things that I can try? Can anyone recommend a US-based third-party for repair? I'd send it in to Otaku's Store, but they're based in France and I'd hate to see the shipping cost for that.

Any help would be very much appreciated.
User avatar
Ziggy587
Next-Gen
 
Posts: 12297
Joined: Mon Jun 09, 2008 5:12 pm
Location: Long Island, NY

Re: 3DO RGB Mod Issues

by Ziggy587 Thu Aug 08, 2019 8:01 am

I'm not at all familiar with the console or the mod to offer any help outside of double checking all connections and checking for bridges. Game-Tech.us has a page of recommended kit installers. Maybe you could reach out to them and see if any can help?

https://www.game-tech.us/recommended-kit-installers/
Image
Return to Technical Help

Who is online

Users browsing this forum: No registered users and 2 guests