Need help with your PC or Modding Projects?
User avatar
scarper
128-bit
 
Posts: 805
Joined: Sat Oct 02, 2010 10:22 pm
Location: Fargo

Yet Another Saturn Disc Drive Problem - Works, But Not Well

by scarper Sun Dec 18, 2016 9:37 pm

Hello all, I have a Model 2 Japanese Saturn with the chip mod I bought from the Racketboy store a few years ago.

The disc drive works... sort of. Games boot, both official and burnt. They seem to play alright for a little while. But occasionally, the game will crash back to the BIOS menu when trying to load something new. In Virtua Fighter 1, this happens after advancing past the 4th stage in arcade mode. In Daytona USA, this happens after finishing a race, sometimes. The music in games will occasionally cut in and out, and while this happens, I can hear the disc drive trying to catch up with itself.

Opened up, checked things out for a bit. Nothing collapsed. Ribbon cables are sitting properly. Mod connections still look alright, and nothing has melted. Tried the "raise it up" trick and that kind of made things better but didn't solve the issue. I'm still getting these symptoms.

Is my disc drive deteriorating? Is this a mod chip problem? I may need to re-do the power supply solder connection since it looks kinda sloppy (it was my first time, modded this YEARS ago.)

Any help with possibly finding the issue would be greatly appreciated. The Saturn is my favorite video game console of all time, so here's hoping I don't need to make any expensive/difficult repairs.

Here are some pictures of the inards:

15658132_10212279977661440_829743083_o.jpg
15658132_10212279977661440_829743083_o.jpg (90.5 KiB) Viewed 1454 times


15631286_10212279965741142_1676620998_o.jpg
15631286_10212279965741142_1676620998_o.jpg (80.74 KiB) Viewed 1454 times


15608570_10212279954140852_1213699112_o.jpg
15608570_10212279954140852_1213699112_o.jpg (86.54 KiB) Viewed 1454 times


15658074_10212279933060325_277873962_o.jpg
15658074_10212279933060325_277873962_o.jpg (55.96 KiB) Viewed 1454 times
User avatar
Ziggy587
Next-Gen
 
Posts: 13096
Joined: Mon Jun 09, 2008 5:12 pm
Location: NY

Re: Yet Another Saturn Disc Drive Problem - Works, But Not W

by Ziggy587 Thu Dec 22, 2016 2:56 pm

I would uninstall the mod chip and then retest the system. See if the issues still persist. If the issues go away, then you'll know the problem was with the mod chip (either the installation or the mod chip itself).
Image

My Sale Thread - SNES and N64 added! I am selling around three quarters of my video game collection as well as some other odds and ends!

I want to buy Universal Game Cases, if you have any spares please PM me! I'm looking to only deal with members that have good BST feedback on this forum.
zyrobs
8-bit
 
Posts: 25
Joined: Tue Jun 09, 2015 5:06 pm

Re: Yet Another Saturn Disc Drive Problem - Works, But Not W

by zyrobs Sat Dec 24, 2016 2:09 pm

Try connecting the modchip power to the positive leg of the C210 cap on the disc drive (it's the one immediately in the front of the unit). That way it'll get properly filtered power, which makes a lot of difference - I've seen modchips that only worked that way.
Return to Technical Help

Who is online

Users browsing this forum: No registered users and 3 guests