Need help with your PC or Modding Projects?
Posts: 1
Joined: Fri Apr 27, 2007 2:11 am

Saturn modchip failure?

by ApM Fri Apr 27, 2007 2:24 am

I picked up a modchip for my US Model 2 Saturn a couple of months ago, but haven't been able to get it to work.

The first time I installed the chip, I used the A+B method. It ran originals fine, but it treated burned games as audio discs. (I was using a burned game that I had successfully booted once with the swap trick, so I'm reasonably sure that the disc wasn't the issue. I also tried to boot the Rockin'-B All Stars homebrew disc, which claims to be region-free, with no effect.) I then modified it to use the signal wire method, only to hit the same result.

I attempted to reseat the modchip and resolder my connections, only to find that my Saturn would no longer boot originals. It would, however, play any CD audio. I attempted to reseat the modchip and resolder my connections again, and now the disc does not even spin up.

The Saturn is fully functional if I plug in the lens cable directly, so I haven't blown it, thankfully, but I have a sinking feeling that I have messed up my modchip. What can I do to figure out what's wrong?
Return to Technical Help

Who is online

Users browsing this forum: No registered users and 8 guests