Need help with your PC or Modding Projects?
tabithaboof
Newbie
 
Posts: 3
Joined: Sat Apr 21, 2007 10:08 am

Saturn Mod Chip install problems.

by tabithaboof Sat Apr 21, 2007 10:21 am

I have a Japanese white saturn with round buttons which internally looks identical to the one on this page

http://www.racketboy.com/retro/2005/01/ ... ation.html

Every time I start up I get the Sega Saturn logo screen, a black screen for a few seconds then a screen with two green cubes and message saying "checking disk format" with no disk activity of any sort. This is the same with back ups, original disks and no disk at all in the machine. The saturn works perfectly with the ribbon cable connected directly to the board.

I have tried a bunch of different variation on my install and regardless of what I the same result. I have tried the following.

- with the AB bridge method
- soldering the signal wired directly to pin 14
- wiggling the modboard while the machine is on
- pushing the modboard in as far as I can
- not pushing the modboard all the way in
- pushing the cd ribbon cable all the way in
- not pushing the cd ribbon cable all the way in
- resoldering the red power cable to the pin shown in the diagram several times

while trying to isolate what I might have done wrong I tried no power cable, no signal cable, no bridge and interestingly ribbon cable/modboard both disconnected and I always get exactly the same result.

I would really love to hear and ideas anyone has, I dont know what the failure rate on the chips is but is it possibly I have a faulty one? Also I read the epic thread over at segaxtreme which gave me alot of the above ideas but still cant get it working.
User avatar
Pullmyfinger
Next-Gen
 
Posts: 1469
Joined: Sat Jan 28, 2006 12:49 pm
Location: Orange County

by Pullmyfinger Sat Apr 21, 2007 11:16 am

Have you tried it in another Saturn??
User avatar
racketboy
Site Admin
 
Posts: 9494
Joined: Thu Dec 01, 2005 8:28 pm
Location: Michigan

by racketboy Sat Apr 21, 2007 12:06 pm

Have you gone through all of this?:
http://www.racketboy.com/retro/2005/06/ ... oting.html
tabithaboof
Newbie
 
Posts: 3
Joined: Sat Apr 21, 2007 10:08 am

by tabithaboof Sat Apr 21, 2007 12:21 pm

Unfortunately the only other Saturn I have is the first grey Japanese one and that appears to be a very different machine from the white one, I wouldn't even know where to start and I dont think my soldering skills are up to modifying this chip.

I hadn't gone through that list of ideas in the trouble shooting guide but all the things I tried seemed to cover it. My soldering is reasonably clean (but im happy to admit I am not expert). I have tried both the AB method and the direct to pin 14 several times, the saturn acts exactly the same way if there is a game/a back up or nothing at all in the machine unless I remove the modboard completely in which cae it works perfectly as an unmodded machine. Also, I am confident that the modboard fits all the way into the slot. It went in first time without any need for filing and im sure its seated well in the machine.

Thanks for the advice but I get the feeling Im either missing something (no idea what it could be) or I got unlucky with a faulty chip.
User avatar
lordofduct
Next-Gen
 
Posts: 2907
Joined: Sat Apr 01, 2006 12:57 pm
Location: West Palm Beach

by lordofduct Sun Apr 22, 2007 11:11 am

this may sound really basic

but did you make sure that the modboard was in the correct direction? the seat it sits in has to have the pins facing the correct direction, make sure you chip isn't backwards.
www.lordofduct.com - check out my blog

Space Puppy Studios - games for gamers by gamers
gutsdozer
Newbie
 
Posts: 1
Joined: Mon Apr 23, 2007 8:51 pm

by gutsdozer Mon Apr 23, 2007 9:01 pm

I'm having the exact same problem. I tried it on two different Saturns.
I noticed the chip in the center of the circuitboard looks like it was scraped or burned - all of the writing is worn off. Could this have anything to do with it?
Image
tabithaboof
Newbie
 
Posts: 3
Joined: Sat Apr 21, 2007 10:08 am

by tabithaboof Wed Apr 25, 2007 2:53 am

I have checked the chip is in the right way round, my install was exactly the same as the diagram. there only seems to be one logical way to install the chip anyway.

I had a look at my chip and the center chip doesn't have the writing burned off, I can read the numbers clearly.
Return to Technical Help

Who is online

Users browsing this forum: No registered users and 5 guests