Need help with your PC or Modding Projects?
velvet
Newbie
 
Posts: 5
Joined: Thu Sep 07, 2006 12:27 pm
Location: Central Ohio

Help - Saturn just quit working!

by velvet Wed Sep 27, 2006 1:29 am

I was playing Guardian Heroes after modding my saturn a couple of weeks ago. I played it the same night I modded it just to make sure it worked and I had a great time! US version, 32 pin round button.

In the middle of playing just a little bit ago, after playing a couple stages (~30-40 minutes) it just froze. Reset - goes to "audio disk" menu. Put in an original - same thing. Then I noticed it's not spinning or making any noises like its trying to spin the disk, period.

Opened it up, nothing was loose, everything is ship-shape. I'm clueless! Don't think solder is the culprit here.

I put all this $ into it and in all I only got to play the Saturn for less than 3 hours total. And yes, it did work before I modded it, I played Rayman for about an hour.

Is it toast? :(
User avatar
racketboy
Site Admin
 
Posts: 9486
Joined: Thu Dec 01, 2005 8:28 pm
Location: Michigan

by racketboy Wed Sep 27, 2006 6:11 am

Open it up and make sure all the connections are soldered well...
You may want to take the chip completely out, see if originals work, and then install it again.;
Something may have come loose.
velvet
Newbie
 
Posts: 5
Joined: Thu Sep 07, 2006 12:27 pm
Location: Central Ohio

by velvet Wed Sep 27, 2006 10:13 am

so it's not necessarily fried even though the disc doesn't even try to spin? I will try removal of the chip when I get home tonight.
Pray for my Saturn... :oops:
User avatar
racketboy
Site Admin
 
Posts: 9486
Joined: Thu Dec 01, 2005 8:28 pm
Location: Michigan

by racketboy Wed Sep 27, 2006 10:33 am

velvet wrote:so it's not necessarily fried even though the disc doesn't even try to spin?


Not necessarily, but we can't really draw any solid conclusions until we experiement a little.
velvet
Newbie
 
Posts: 5
Joined: Thu Sep 07, 2006 12:27 pm
Location: Central Ohio

by velvet Wed Oct 04, 2006 8:15 pm

well i read on here through the other broken saturn threads, and came upon one where the disc wasn't even attempting to spin, just like mine. i just tried and i can't find that specific post on here.

so instead of taking mine apart, i did what he said fixed his occaisionally, I thought he said something about moving or pressing on the laser assembly or the disc spinner. So being careful not to touch the laser, I prodded around in there with the case on. Pressed on the disc spinner and since it's pretty hard not to touch the laser, i really only gently nudged that assembly and stuck my pinky in the slot and touch the cable (hehe that sounds naughty...).

well hey after that it spun up just fine and loaded my burned guardian heroes. I'll report back if problems persist...
User avatar
racketboy
Site Admin
 
Posts: 9486
Joined: Thu Dec 01, 2005 8:28 pm
Location: Michigan

by racketboy Wed Oct 04, 2006 8:17 pm

velvet wrote:well i read on here through the other broken saturn threads, and came upon one where the disc wasn't even attempting to spin, just like mine. i just tried and i can't find that specific post on here.

so instead of taking mine apart, i did what he said fixed his occaisionally, I thought he said something about moving or pressing on the laser assembly or the disc spinner. So being careful not to touch the laser, I prodded around in there with the case on. Pressed on the disc spinner and since it's pretty hard not to touch the laser, i really only gently nudged that assembly and stuck my pinky in the slot and touch the cable (hehe that sounds naughty...).

well hey after that it spun up just fine and loaded my burned guardian heroes. I'll report back if problems persist...


Is yours modded?
velvet
Newbie
 
Posts: 5
Joined: Thu Sep 07, 2006 12:27 pm
Location: Central Ohio

by velvet Wed Oct 04, 2006 10:14 pm

racketboy wrote:
velvet wrote:well i read on here through the other broken saturn threads, and came upon one where the disc wasn't even attempting to spin, just like mine. i just tried and i can't find that specific post on here.

so instead of taking mine apart, i did what he said fixed his occaisionally, I thought he said something about moving or pressing on the laser assembly or the disc spinner. So being careful not to touch the laser, I prodded around in there with the case on. Pressed on the disc spinner and since it's pretty hard not to touch the laser, i really only gently nudged that assembly and stuck my pinky in the slot and touch the cable (hehe that sounds naughty...).

well hey after that it spun up just fine and loaded my burned guardian heroes. I'll report back if problems persist...


Is yours modded?


I'm the OP of this thread. Read first post...
Return to Technical Help

Who is online

Users browsing this forum: No registered users and 6 guests