Guides to jumpstart your Retrogaming lifestyle
User avatar
CRTGAMER
Next-Gen
 
Posts: 11933
Joined: Tue Jan 05, 2010 11:59 am
Location: Southern California

Re: Sony Trinitron WEGA RLOD Twenty Dollar Repair Guide

by CRTGAMER Thu Jan 17, 2013 9:07 pm

jh41 wrote:THANKS SO MUCH for ALL this info, pictures, walkthrough, tips, etc!!!
I am new to this site (found it when searching for sony blink codes)

Using this forum, I (just today) fixed my Sony 40" HDTV Trinitron (Sony 40XBR700)

It works great now.
I also want to give mad props for the hair dryer trick. Worked for me for about a month, and I started leaving TV on throughout the day...

But yes, installed the sockets with the chips, so more future-proof.
Also, solder sucker purchased off ebay was definitely the way to go. (also got the 2 chips/sockets off ebay for $17.75)

Thanks again for this forum!
Congrats on repairing you Trinitron. Nice to read another HD CRT is saved, thanks for posting!

garbanzo wrote:I completed the repair yesterday and my set is now back to working again (whew!). Thanks for the great info, especially about removing the board without having to disconnect the flyback. But when I fired up the TV I now have a new problem which isn't killer but it is one I'd like to fix. I don't know if I bumped something but the picture is now rotated about 15 degrees counter clockwise, rather than being level. Basically the way to think of it is that a straight horizontal line would show up as slanting from lower left to upper right at about a 15 degree angle. In the old days it'd be that the yoke was turned a little.

I went into Setup with the remote and there is an adjustment for tilt but it doesn't seem to have any effect. I'm sure the answer is in some post as to how to go into service mode and make this particular adjustment but I haven't been able to find it.

I would greatly appreciate any info someone might have that might help me solve this problem. Thank you in advance! If need be I can take a shot showing the rotated picture and post it.
Glad you got the TV working again aside from the rotation issue. It does sound like the back of the CRT gun might have been bumped throwing the angle off. There is a hidden Sony Service Menu that might be the answer. Be careful, a wrong setting could brick you TV!

THE SONY SERVICE CODES - http://www.avsforum.com/t/531494/the-so ... iscoveries

Please post a screenshot to show exactly what is going on. Which Model number?
Image
CRT vs LCD - Hardware Mods - HDAdvance - Custom Controllers - Game Storage - Wii Gamecube and other Guides:
CRTGAMER Guides in Board Guides Index: http://www.racketboy.com/forum/viewtopic.php?p=1109425#p1109425

Image
Image
garbanzo
Newbie
 
Posts: 2
Joined: Mon Jan 14, 2013 1:03 pm

Re: Sony Trinitron WEGA RLOD Twenty Dollar Repair Guide

by garbanzo Tue Feb 05, 2013 5:33 pm

Sorry for the long delay since your response but I've been out of town for the last 3 weeks. A couple things have occured. The attached photo shows what the rotated picture. I was able to find the service codes and went in to make adjustments but haven't had any success. There are adjustments for pining, trapezoid, etc but none for rotating while maintaining the same geometry. On top of that I'm now back to getting 7 blinking lights. As much as I like the set I'm probably going to junk it and buy a flat screen. But it was a fun project while it was going well. Thanks for the help. If you have any additional suggestions about why I'm back to 7 lights (would there be some other component which is causing the ICs to blow?) or how to rotate the picture to the correct geometry, please let me know. I checked the deflection coils and they are locked in place so I'm 99% sure the rotation problem wasn't caused by physically bumping anything.
1DSC04469.jpg
Screen shot of rotated picture after changing ICs
1DSC04469.jpg (307.45 KiB) Viewed 2810 times
User avatar
CRTGAMER
Next-Gen
 
Posts: 11933
Joined: Tue Jan 05, 2010 11:59 am
Location: Southern California

Re: Sony Trinitron WEGA RLOD Twenty Dollar Repair Guide

by CRTGAMER Mon Feb 11, 2013 3:44 pm

garbanzo wrote:I was able to find the service codes and went in to make adjustments but haven't had any success. There are adjustments for pining, trapezoid, etc but none for rotating while maintaining the same geometry.

On top of that I'm now back to getting 7 blinking lights. As much as I like the set I'm probably going to junk it and buy a flat screen. But it was a fun project while it was going well. Thanks for the help. If you have any additional suggestions about why I'm back to 7 lights (would there be some other component which is causing the ICs to blow?) or how to rotate the picture to the correct geometry, please let me know. I checked the deflection coils and they are locked in place so I'm 99% sure the rotation problem wasn't caused by physically bumping anything.

The seven lights again looks like either a bad solder connection or a marginal chip. Did you use the revised B series chips? For now, try swapping the two chips if you installed a set of Chip Sockets. If that does not work or you did not install sockets, give each chip leg a quick remelt.

MCZ3001DB
If the chips are not the B series, you might look into buying a set, an under twenty dollar investment.

Not sure on the Service codes, I avoid using it due to the risk of bricking the TV. In your case a necessity due to how bad your screen is rotated. The chips are certainty not the issue for the display problems since they only detect the powerup phase. If you ever get your TV up and running the service code for rotation has to be in there somewhere, the regular setup menu just does not rotate it enough. Perhaps someone in the AVS Forum might know a way, linked in my previous reply.
Image
CRT vs LCD - Hardware Mods - HDAdvance - Custom Controllers - Game Storage - Wii Gamecube and other Guides:
CRTGAMER Guides in Board Guides Index: http://www.racketboy.com/forum/viewtopic.php?p=1109425#p1109425

Image
Image
User avatar
CRTGAMER
Next-Gen
 
Posts: 11933
Joined: Tue Jan 05, 2010 11:59 am
Location: Southern California

Re: Sony Trinitron WEGA RLOD Twenty Dollar Repair Guide

by CRTGAMER Sat Jul 13, 2013 5:04 pm

meat wrote:Image
Anything I can do?? Somebody said magnets but how?? I haven't turn this TV on in 4 months. The green has gotten less and less since I let the tv just run for awhile.

Make and Model of the TV?
Agree it does appear to be a "magnetic interference" caused issue. Try moving any external components such as external speakers and anything else that has power away from the TV. Sometimes even rearranging the cables, especially power cables helps. The TV has a built in Degauss designed to get rid of magnetic buildup. You can tell it works by a slight pop sound emanating from the tube when you turn on the TV. However, I would not turn the TV off and on to try to fix it, due to the risk I mentioned in the OP. Even if yours may not have the marginal chips, no reason to surge any TV like that.

Based on your description, the color is improving. See what happens in the next week or so with one power on per day cycle. Maybe the internal Degaus might be faulty or it might fix the light show, time will tell. You can get a handheld commercial Degaus Wand or have a TV Repair try that, but this can be expensive and would very likely be only a temporary fix.

If you still have issue after a few days, move the TV so it is free standing away from anything else electrical and try that for a couple of days. This will confirm if TV is at fault (Faulty Internal Degauss) or if something nearby causing the interference.
Image
CRT vs LCD - Hardware Mods - HDAdvance - Custom Controllers - Game Storage - Wii Gamecube and other Guides:
CRTGAMER Guides in Board Guides Index: http://www.racketboy.com/forum/viewtopic.php?p=1109425#p1109425

Image
Image
User avatar
meat
64-bit
 
Posts: 316
Joined: Wed Dec 22, 2010 7:51 pm
Location: eastern nc

Re: Sony Trinitron WEGA RLOD Twenty Dollar Repair Guide

by meat Sun Jul 14, 2013 7:29 am

Thanks for the quick feedback.I will update in a week.
youtube@gamingtrucker1
twitter@gamingtrucker1
twitch@gamingtrucker1
User avatar
meat
64-bit
 
Posts: 316
Joined: Wed Dec 22, 2010 7:51 pm
Location: eastern nc

Re: Sony Trinitron WEGA RLOD Twenty Dollar Repair Guide

by meat Sun Jul 14, 2013 11:01 am

Image
Well it is fixed.Just turn it on and no green.
youtube@gamingtrucker1
twitter@gamingtrucker1
twitch@gamingtrucker1
User avatar
CRTGAMER
Next-Gen
 
Posts: 11933
Joined: Tue Jan 05, 2010 11:59 am
Location: Southern California

Re: Sony Trinitron WEGA RLOD Twenty Dollar Repair Guide

by CRTGAMER Sun Jul 14, 2013 12:11 pm

meat wrote:Well it is fixed.Just turn it on and no green.

Great! Looks like the internal Degauss just needed a couple of cycles to do its magic. I am curious what was next to it when it was not turned off in four months.
Image
CRT vs LCD - Hardware Mods - HDAdvance - Custom Controllers - Game Storage - Wii Gamecube and other Guides:
CRTGAMER Guides in Board Guides Index: http://www.racketboy.com/forum/viewtopic.php?p=1109425#p1109425

Image
Image
User avatar
meat
64-bit
 
Posts: 316
Joined: Wed Dec 22, 2010 7:51 pm
Location: eastern nc

Re: Sony Trinitron WEGA RLOD Twenty Dollar Repair Guide

by meat Sun Jul 14, 2013 12:25 pm

metal air vent cover.I just sat it on the floor.
youtube@gamingtrucker1
twitter@gamingtrucker1
twitch@gamingtrucker1
User avatar
CRTGAMER
Next-Gen
 
Posts: 11933
Joined: Tue Jan 05, 2010 11:59 am
Location: Southern California

Re: Sony Trinitron WEGA RLOD Twenty Dollar Repair Guide

by CRTGAMER Sun Jul 14, 2013 3:24 pm

meat wrote:metal air vent cover.I just sat it on the floor.

Ah, an electric heater maybe? The coils inside even off might have done that.

Or maybe just the TV sitting for so long turned off. Now see that, proves my theory that CRTs do not want to left neglected and turned off! :lol:
Image
CRT vs LCD - Hardware Mods - HDAdvance - Custom Controllers - Game Storage - Wii Gamecube and other Guides:
CRTGAMER Guides in Board Guides Index: http://www.racketboy.com/forum/viewtopic.php?p=1109425#p1109425

Image
Image
User avatar
CRTGAMER
Next-Gen
 
Posts: 11933
Joined: Tue Jan 05, 2010 11:59 am
Location: Southern California

Re: Sony Trinitron WEGA RLOD Twenty Dollar Repair Guide

by CRTGAMER Wed Aug 06, 2014 11:37 am

D.D.D. wrote:Hey CRTGamer~

So bad news... my Wega Trinitron seems to be struggling to turn on these days. It still turns on but some days, when I hit the master power and it makes its "dooooon", on bad days that "dooooon" is gone or very minimal compared to usual.
It also did a 5x LED error blink, which according to Sony's service center means "something is wrong internally"... So vague. It made that LED blink once but went away the next day and worked fine for another week or so before making a weak "dooon" on power up again.

So what parts (if they have them still) should I make sure to check that they're replacing? The IC chips were replaced about 5 years ago by the previous owner (I assume those are still good...) but what about capacitors or a power board?

Thanks!

Weird coincidence that you brought this up. My bedroom HDCRT WEGA spare is also starting to act up shutting off by itself. Unlike the repaired twin in the living room, the bedroom Sony has not had the power detection chip upgrade yet and still has the older chips. I unplugged it for a week and was going to start the desolder then decided one more test run. Plugged it back in this morning (turns on as soon as plugged in) and so far has been on for a few hours. As an interim until you obtain the chips, maybe unplug your TV for a few days?

To minimize power surges of warmed up components and the power detection chips, only turn on the Trinitron WEGA once a day once you get it fired back up.

Your power detection chips could have failed again, especially if not the revised set. Even the upgraded chips have been known to fail. Possible good news is if the previous owner installed BOTH of the replacement Power Detection chips and also installed with sockets, the WEGA could be a very easy fix. A simple matter of popping in replacement chips. Be sure the newer revised chips are MCZ3001DB with the B in the model number. I would go the inexpensive chip route which usually is the cause before diving further with capacitor replacement.

See the OP for the repair and be careful of high voltage around the fat wire Flyback Transformer and back of the tube even when unplugged. Hope you have the sockets already installed, please post an update of which model chips are inside (maybe pics) along with the TV Model Number. Good Luck on the repair and hope you have sockets inside.

EDIT
It is now 6:45pm, a good sign the chips might hold out for at least a little while longer. The Sony HDCRT TV has been on for almost 12 hours straight. That unplug the power for a week seemed to help at least for the short term. I'll post an update if anything changes. :D

Image
Image
CRT vs LCD - Hardware Mods - HDAdvance - Custom Controllers - Game Storage - Wii Gamecube and other Guides:
CRTGAMER Guides in Board Guides Index: http://www.racketboy.com/forum/viewtopic.php?p=1109425#p1109425

Image
Image
Return to Guides

Who is online

Users browsing this forum: No registered users and 1 guest