Discuss all hardware and software modifications
User avatar
Ghudda
128-bit
 
Posts: 520
Joined: Thu Nov 07, 2013 12:47 pm
Location: North Texas

GBA AGB-001 AGS-101 backlight mod issue!

by Ghudda Tue Mar 24, 2015 10:49 pm

Anyone here familiar with the AGS 101 screen mod for the original GBA? I've had an adapter sitting around forever and am trying to get it to work but am having some issues which I think may lay in the adapter. I tested the screen before trying this so I can't see there being a problem with the display itself.

Basically the screens backlight is lighting up but nothing else. No GBA splash screen or anything. My soldering looks fine and is obviously working or the backlight wouldn't be getting powered, correct?

Do the solder points on the adapter look normal to everyone? I'm using a 32 pin adapter on a 32 pin GBA (board # 10 4-2) with a 32pin GBA SP screen.

Anything look fishy to anyone?

Image
Image
Image
Image
User avatar
Ghudda
128-bit
 
Posts: 520
Joined: Thu Nov 07, 2013 12:47 pm
Location: North Texas

Re: GBA AGB-001 AGS-101 backlight mod issue!

by Ghudda Wed Mar 25, 2015 11:16 am

I should also note that the console does actually boot up and i'm able to hear the splash screen music as well as see the splash screen on the original AGB 001 screen, just not the AGS 101.
User avatar
nightrnr
Next-Gen
 
Posts: 1722
Joined: Thu Jun 17, 2010 5:56 pm

Re: GBA AGB-001 AGS-101 backlight mod issue!

by nightrnr Wed Mar 25, 2015 1:31 pm

Is your ribbon cable plugged in the right way? I'm not positive, but it looks backwards to me (white part should be on bottom I thought). I can confirm that it looks different on another tutorial:
http://forums.modretro.com/viewtopic.php?f=40&t=13374
(click on pic# 5)

I'd Switch it around and see what happens...
...just another lost soul...
User avatar
Ghudda
128-bit
 
Posts: 520
Joined: Thu Nov 07, 2013 12:47 pm
Location: North Texas

Re: GBA AGB-001 AGS-101 backlight mod issue!

by Ghudda Wed Mar 25, 2015 2:10 pm

nightrnr wrote:Is your ribbon cable plugged in the right way? I'm not positive, but it looks backwards to me (white part should be on bottom I thought). I can confirm that it looks different on another tutorial:
http://forums.modretro.com/viewtopic.php?f=40&t=13374
(click on pic# 5)

I'd Switch it around and see what happens...

I see what you're saying but how the contacts are situated in the connector and it possibly being backwards, the way I have it is the only way that the contacts connect to one another. If I put the ribbon cable in as seen in the photo, the backlight doesn't even come on.
User avatar
nightrnr
Next-Gen
 
Posts: 1722
Joined: Thu Jun 17, 2010 5:56 pm

Re: GBA AGB-001 AGS-101 backlight mod issue!

by nightrnr Wed Mar 25, 2015 5:36 pm

Well, my link was apparently from a failed attempt too, so it's not the best example either. It was just the only decent pic I could find at the time.

If I'm not mistaken (although entirely possible), the back-light itself is powered by the extra wire that you solder. I'm not sure why the ribbon cable orientation should even effect the light.
You may have had the cable in right in your pic, it just looked odd to me,and I swear that some tutorials have it the other way. Most info is in the form of a video, so I can't link a proper pic.

Ribbon cables are also notoriously easy to damage, but yours looks in good enough shape from your pics. Otherwise, sometimes it can help to check if the cable is inserted far enough (or even too far?).

In any case, Good luck. I'll share more if I find anything.

--EDIT--
I did just check my semi functional GBA that has the adapter and a SP screen with removed frontlight (don't ask). It shows the ribbon cable pretty much like you had it (white portion on same side as soldered wire). The screen loads up normally.
...just another lost soul...
User avatar
Ghudda
128-bit
 
Posts: 520
Joined: Thu Nov 07, 2013 12:47 pm
Location: North Texas

Re: GBA AGB-001 AGS-101 backlight mod issue!

by Ghudda Wed Mar 25, 2015 10:44 pm

thanks for the help, nightmr. I'm also thinking the adapter itself may be damaged (could be the solder joints connecting the pins to the socket where the AGS101 screen connects) and not the screen or GBA itself. I've ordered another adapter and hopefully it works. I'll post updates when it gets here and yeah let me know if you think of or find anything else!
User avatar
jay_red
Next-Gen
 
Posts: 1734
Joined: Sun Nov 07, 2010 2:05 am

Re: GBA AGB-001 AGS-101 backlight mod issue!

by jay_red Wed May 13, 2015 12:02 am

I have done this mod twice, the first went perfect, and is my normal GBA I play all the time, the 2nd had the same issue you had. After getting frustrated with it and shelving it for a while I decided to look into it again and figure out what went wrong, and I realized I was using a 40 pin GBA, 40 pin adapter, but a 32 pin screen, so i need to order the correct cable, and use the 32 pin board I have kicking around.

I know this isnt too useful for you, but when I hooked it up it looked exactly like you showed, so maybe your cable isnt what you thought it was?
My trade thread, updated 7/14
viewtopic.php?f=22&t=30531&p=421248#p421248
Return to Hacks and Mods

Who is online

Users browsing this forum: No registered users and 5 guests