Page 1 of 2

Dreamcast powers on, but no video/audio, disc doesn't spin

Posted: Thu Aug 08, 2019 10:13 am
by Mad_Hatter
My Dreamcast powers on (it gets the orange light). However, there is no video/audio, and the disc is not spinning. The fan is on. And I got the VMU beep so I think my controller is getting power.

Anyways, what do you think the issue is?

Small Details:
- I noticed this two days ago. I turned on my Dreamcast. I thought I heard a small zap inside the system. I didn't think much of it (I've heard worse from my computer which still works after 10 years). There was no audio/video. I tried it again, and it worked. I got a signal. Then yesterday, when I tried to turn it on again, my TV would not get a signal and the disc would not spin even after a few tries and cable wiggles.
- The PSU is emitting a smell that I did not notice before when it was working. And could feel some significant heat from the PSU (felt it through the shell too). This is something I did not notice before either. Though this could all be because I am up close to the system and inspecting it.
- I hear a sound from my TV when I turn on the DC, as if the TV is recognizing that the DC is trying to send it a signal.
- I don't think it's the A/V cables, because the disc should still be spinning, right?
- I never had issues with my DC before. I do play backups.
- I noticed that it was dusty and there was some hair in there. Would cleaning it help at all?

This is my childhood Dreamcast, so I would like to repair it rather than replace it. And the price of DCs have gone up in my area.

Here are some photos of the PSU, which I think is the problem:

https://imgur.com/a/N8LQsTY

That big thing in the middle is where I can feel most of the heat from.

Should I replace my PSU with something like this?:

https://ebay.us/sq6H2K

If the PSU was the problem and it is replaced with a working one, is there a chance the old PSU shorted some of my other components (like the laser and disc motor)?

Another note:
I was wondering why my DC did this, even though I don't play it much at all? I noticed that while it has been off a long time, the bottom would still be a little warm. And that is because 2-3 months ago, I installed a AT&T Uverse box (which can get quite hot) for this TV. That box is right under the DC platform and that ATT box's heat transfers to the wooden platform about it (it's a pretty crowded space). So the DC is getting heat from below. Could this been an issue? But at the same time, this DC survived 10 years (10 summers) in an attic without being turned on.

Re: Dreamcast powers on, but no video/audio, disc doesn't sp

Posted: Thu Aug 08, 2019 10:55 am
by pierrot
That big thing in the middle is a transformer, and yeah, it should get hot. The question would really be whether or not it’s abnormally hot, which may suggest a worn down transformer, or a short somewhere.

It’s hard for me to see it too clearly on my phone, but there appears to be some foreign substance near the 8-pin DIP IC, and the smaller electrolytic capacitor by that transformer. Seems like it could be solder flux, soda, or leakage from one of the caps. Any of those things are potentially an issue. Cleaning it would be something to try, anyway. I’d start there.

Re: Dreamcast powers on, but no video/audio, disc doesn't sp

Posted: Thu Aug 08, 2019 11:31 pm
by Mad_Hatter
I tried cleaning it up, no luck.

I wonder if this could be the issue? One of the switch wires almost looks like it was cutoff completely.

20190808_222844.jpg
20190808_222844.jpg (386.64 KiB) Viewed 1273 times


It might be barely connected. Is this the issue; or if it is turning on, is the switch doing its job?

Re: Dreamcast powers on, but no video/audio, disc doesn't sp

Posted: Thu Aug 08, 2019 11:44 pm
by samsonlonghair
If I was standing in your shoes, I would grab a multimeter and start testing connections around that switch and around the power supply. I might also look up a service manual or schematic for the Dreamcast to reference what should be connected.

From there it’s mostly just taking the time to carefully test all the relevant circuits. You can use logic to figure out what component has failed. :idea:

Then see if you can source a replacement. Luckily a Dreamcast is still relatively cheap. I would look for one with good working components but bad cosmetic condition. Then you can swap out parts to prove your testing right or wrong. Eventually you will land on a working solution.

I believe in you; you can do this. Your childhood Dreamcast will live again!

Re: Dreamcast powers on, but no video/audio, disc doesn't sp

Posted: Fri Aug 09, 2019 7:59 am
by Ziggy587
That replacement PSU that you linked to from eBay is cheap enough that I would just get it to swap in and test.

You can poke around with a multimeter, which is probably what I would do, but just use caution. Even after it's powered off, some of the caps might still be holding a charge. Bridging something with the multimeter probes could short something and at the very least blow a fuse.

Re: Dreamcast powers on, but no video/audio, disc doesn't sp

Posted: Fri Aug 09, 2019 11:26 am
by pierrot
So, I can’t quite tell from the picture, but it sounds like, from your description, that you’ve got stranded wire that’s fraying above the solder joint. If that’s the case, it’s going to cause overheating. Wire diameter determines the maximum allowable current through a wire (resistance is inversely proportional to the diameter). Stranded wire, to make it more flexible, and less likely to break inside the insulation, wraps a bunch of smaller diameter wires together, but if any of the strands are broken, it reduces that current capacity of the wire. So if the wire was meant to carry an amp, the maximum rating for the gauge of wire is 2 amps, but it’s stranded, and 3/4 of the strands are broken, then you now have a wire that can only withstand about half an amp. That ‘overcurrent’ on the wire is going to manifest itself as heat, and probably cause some extra damage to the wire at least.

TL;DR if that wire is frayed, you want to replace it.

Re: Dreamcast powers on, but no video/audio, disc doesn't sp

Posted: Fri Aug 09, 2019 12:43 pm
by Mad_Hatter
pierrot wrote:So, I can’t quite tell from the picture, but it sounds like, from your description, that you’ve got stranded wire that’s fraying above the solder joint. If that’s the case, it’s going to cause overheating. Wire diameter determines the maximum allowable current through a wire (resistance is inversely proportional to the diameter). Stranded wire, to make it more flexible, and less likely to break inside the insulation, wraps a bunch of smaller diameter wires together, but if any of the strands are broken, it reduces that current capacity of the wire. So if the wire was meant to carry an amp, the maximum rating for the gauge of wire is 2 amps, but it’s stranded, and 3/4 of the strands are broken, then you now have a wire that can only withstand about half an amp. That ‘overcurrent’ on the wire is going to manifest itself as heat, and probably cause some extra damage to the wire at least.

TL;DR if that wire is frayed, you want to replace it.

Yep. You described it about right. Here is another picture and more large and clear

https://imgur.com/a/8sLTXr6

I got another switch with wires coming in and a new power supply. Should I try replacing the switch first in case my current power supply is good? Or should I just replace both because current power supply was emitting all that heat and smell?

You think there is a chance this cooked other components?

Re: Dreamcast powers on, but no video/audio, disc doesn't sp

Posted: Fri Aug 09, 2019 1:14 pm
by pierrot
Yeah, I’m just trying to think about the circuit from memory here. I’m pretty sure that switch is controlling the input to the power supply board. The transformers could have been overworked trying to compensate for the sag in the line current. That might have been why the transformer was so warm, if it was warmer than usual. It could still be okay though. I’d probably start with the switch, clean the power supply up, and monitor it when you power it up.

Re: Dreamcast powers on, but no video/audio, disc doesn't sp

Posted: Mon Aug 12, 2019 10:32 pm
by Mad_Hatter
Replacing just the switch didn't work.

But replacing the PSU worked and it booted up very quickly.

Thanks for all the help guys

Re: Dreamcast powers on, but no video/audio, disc doesn't sp

Posted: Mon Aug 12, 2019 11:46 pm
by samsonlonghair
Mad_Hatter wrote:Replacing just the switch didn't work.

But replacing the PSU worked and it booted up very quickly.

Thanks for all the help guys

I never doubted you for a moment, hatter. I knew you could get your Dreamcast running again.