Need help with your PC or Modding Projects?
chriswy27
8-bit
 
Posts: 42
Joined: Wed Nov 22, 2006 5:41 pm

Sega Hi-Saturn Video Issue IC10 VDP1 or IC13 SRam

by chriswy27 Wed Nov 29, 2017 12:30 am

Video: https://www.youtube.com/watch?v=piYHNuaIXgU

TLDR: Video issues with my Hi-Saturn. Looks like VDP1 or Ram. Skip to 1:25 to see issue.

Calling all Saturn hardware guys. Having an issue with my Hi-Saturn MMP-11 VA9. The video display sometimes has issues such as lines on the highlighted field or a complete grid of white dots on the set date screen. This will carry into the CD player as well. When the saturn warms up the issue goes away but returns after its been off a while. 1) Originally thought it was a power supply but swapped another and had the same issue. 2) Looked over all the caps with a magnifying glass and they look mint though I know they could still be bad. 3) Started pressing on chips when it was on and found putting pressure on the IC10 VDP1 and IC13 SRAM would make the issue go away and releasing would make it return. To me this would seem like I have a chip solder connection issue but I am no expert. Both chips are located at the same place on opposite sides of the board so I am unable to determine which is the culprit.

Questions 1) With pressure making the issue go away it would seem like the IC's themselves are fine but the solder connection is bad, right? 2) IC13 says 2Mbit x 16 x 2 Banks. Online I can only find 2M x 16 x 4 Banks. Do the 2 banks need to match as well or is that irrelevant? Asking in case I need to replace the ram chip.

I'd like to fix this instead of replacing as it's a lightly used Hi-Saturn which is semi-rare. Thanks!
Return to Technical Help

Who is online

Users browsing this forum: No registered users and 1 guest