SMS, Genesis, 32X, Sega CD, Saturn, Dreamcast
Hamburglar
8-bit
 
Posts: 29
Joined: Sun Apr 15, 2007 12:49 pm

Is my Sega Saturn dying? Or is it something else?

by Hamburglar Sun Apr 15, 2007 12:54 pm

I've been a proud owner of a Sega Saturn since launch, and recently successfully modded it to get a chance to play some of the extremely expensive games (Panzer Dragoon Saga, etc) that I could never afford ebay's ridiculous prices. I hate resorting to piracy, but I'm not paying $200 for a game in which Sega will see no money from.

Anyway, I've been enjoying some backups, and recently got some games online to burn. Only about half of them work, but I know it's something I'm doing, as a friend of mine downloaded the same games and had no problems playing them. Most of the time when I try to boot a backup, it goes to the CD player menu, and says No Disk, or just tries to play it as a music CD. If I try to reboot the system two or three times, I can finally get the game to boot. I am positive my chip is installed properly.

I've used every burning program on earth, and typically use Alcohol 120. I've tried different speeds, media, programs, nothing makes a difference. It's weird though, some games boot just fine every time, and some games boot once in a while, and some none at all. And they are all being burnt the same! This has nothing to do with region settings since these are all US games I am burning.

I would really appreciate some insight. I am ripping my hair out over here and burned so many CD's I threw out I might as well have bought Panzer Dragoon anyway.
User avatar
ImportBoy
64-bit
 
Posts: 412
Joined: Sat Jan 06, 2007 11:00 pm
Location: New Jersey; United States

by ImportBoy Sun Apr 15, 2007 1:24 pm

Perhaps the mod chip or the wiring is loose? You might want to make sure everything is firmly inserted and connected. Have you checked inside the system?
-ImportBoy
Over 700 Saturn Games Available - Downloads, Information, & How To Guides
http://www.sega-saturn.us - kaneda@sega-saturn.us
Hamburglar
8-bit
 
Posts: 29
Joined: Sun Apr 15, 2007 12:49 pm

by Hamburglar Sun Apr 15, 2007 1:53 pm

ImportBoy wrote:Perhaps the mod chip or the wiring is loose? You might want to make sure everything is firmly inserted and connected. Have you checked inside the system?


Yep, just re-did it. It's very specific which games work every time, some times, and never.
User avatar
racketboy
Site Admin
 
Posts: 9461
Joined: Thu Dec 01, 2005 8:28 pm
Location: Michigan

by racketboy Sun Apr 15, 2007 2:11 pm

Hamburglar wrote:
ImportBoy wrote:Perhaps the mod chip or the wiring is loose? You might want to make sure everything is firmly inserted and connected. Have you checked inside the system?


Yep, just re-did it. It's very specific which games work every time, some times, and never.


That may mean that there is something wrong with some of the ISOs or burns if certain ones are having problems.
Hamburglar
8-bit
 
Posts: 29
Joined: Sun Apr 15, 2007 12:49 pm

by Hamburglar Sun Apr 15, 2007 2:13 pm

racketboy wrote:
Hamburglar wrote:
ImportBoy wrote:Perhaps the mod chip or the wiring is loose? You might want to make sure everything is firmly inserted and connected. Have you checked inside the system?


Yep, just re-did it. It's very specific which games work every time, some times, and never.


That may mean that there is something wrong with some of the ISOs or burns if certain ones are having problems.


I'd agree but some boot after like 2 or 3 tries. Either an ISO works or not, from my experience.
User avatar
racketboy
Site Admin
 
Posts: 9461
Joined: Thu Dec 01, 2005 8:28 pm
Location: Michigan

by racketboy Sun Apr 15, 2007 4:09 pm

Hamburglar wrote:
racketboy wrote:
Hamburglar wrote:
ImportBoy wrote:Perhaps the mod chip or the wiring is loose? You might want to make sure everything is firmly inserted and connected. Have you checked inside the system?


Yep, just re-did it. It's very specific which games work every time, some times, and never.


That may mean that there is something wrong with some of the ISOs or burns if certain ones are having problems.


I'd agree but some boot after like 2 or 3 tries. Either an ISO works or not, from my experience.


Unless the CD media is mediocre.
User avatar
marurun
Moderator
 
Posts: 10060
Joined: Sat May 06, 2006 8:51 am
Location: Cleveland, OH

by marurun Sun Apr 15, 2007 4:09 pm

Well, CD-Rs are harder to read (require more powerful lasers) than regular CDs. Perhaps you need to clean or realign the lens.
B/S/T thread
My Classic Games Collection
My Steam Profile
The PC Engine Software Bible Forum, with Shoutbox chat - the new Internet home for PC Engine fandom.
User avatar
ImportBoy
64-bit
 
Posts: 412
Joined: Sat Jan 06, 2007 11:00 pm
Location: New Jersey; United States

by ImportBoy Sun Apr 15, 2007 4:10 pm

If the mod chip is all good it sounds like the Saturn may have trouble reading the CDs.

It might be your burner or the blank media your using. Might want to try switching to a different burner if you can and/or try a different brand of blank CDs. Are you burning at 8x or less speeds also?

If your friend is downloading and burning the exact same images without issue, then I don't think the images are the problem.
-ImportBoy
Over 700 Saturn Games Available - Downloads, Information, & How To Guides
http://www.sega-saturn.us - kaneda@sega-saturn.us
Hamburglar
8-bit
 
Posts: 29
Joined: Sun Apr 15, 2007 12:49 pm

by Hamburglar Sun Apr 15, 2007 4:17 pm

Thanks for all the help so far guys.

I've tried two different types of media, first was Phillips, second was Verbatim (high quality). I luckily also have two different burners, one a Pioneer and one an NEC, both yield the same results.

Funny thing is sometimes the games I can get to work burning at 4x, sometimes I will have to burn at max speed for it to work.

I did try cleaning my Saturn's lens with a q-tip and rubbing alcohol.

Maybe I can upload an iso here I am using that 100% does not work for me and you guys can tell me if it works?
User avatar
ImportBoy
64-bit
 
Posts: 412
Joined: Sat Jan 06, 2007 11:00 pm
Location: New Jersey; United States

by ImportBoy Sun Apr 15, 2007 4:33 pm

What game is it? You might want to try grabbing a couple from my site to try (www.sega-saturn.us). If you've tried both burners I think your next option would be to tweak the laser.

Is your Saturn playing original games fine?
-ImportBoy
Over 700 Saturn Games Available - Downloads, Information, & How To Guides
http://www.sega-saturn.us - kaneda@sega-saturn.us
Return to Sega

Who is online

Users browsing this forum: Google [Bot] and 4 guests